Friday, 4 March 2016

Tesco Hudl2 battery problems and teardown

The Hudl2 is an excellently priced android-based tablet sold by Tesco in the UK for a while. Unfortunately they have now discontinued the range and so no more will be produced. Their price-point of under £100 and has an 8.1" screen, full HD, stereo speakers, quad-core 1.8Ghz processor, 2Gb RAM, 16Gb storage built-in and a 5 megapixel rear camera and 1.2 megapixel front-facing camera. So a pretty decent spec for the money.
My youngest had one and it's done well, lasted around 2 years of abuse, mainly around the charge socket as usual it's micro-usb and this is the weak point, the cables were abused quite badly and over time gave up, so swapping cables quite often solved it. That was until the last time, when the cable seemed to have shorted, so the tablet was left for a few weeks totally flat.
Plugging it in to charge wouldn't give the red charging light, which worried me as normally charge lights are hard-wired to the voltage input, so it not coming on was a bad sign, was the usb port damaged or worse.

What makes it more complicated is the hudl2 comes with a USB charger, but with non-standard specs, it's the usual 5v output but it's 2.0A which is a lot higher than normal (usb port is 0.5A), so that would suggest the hudl2 uses fast/high-powered charge. I therefore wasn't sure what the cable needed to be (We'd thrown out the damaged cable, a stupid move in hindsight!). Luckily the charger itself was OK and charging other USB devices fine.



So I suspected the hardware, popping the cover off is easy, just a flat screwdriver gently prising around the outside of the case at the seam will take the back cover off, just pop it open and it comes into two neat halves (no wires to worry about popping out, etc, the rear cover is purely a cover).



There in the middle you can see the 'battery pack'. This consists of two 3.8v li-ion batteries in parallel which I assume is to provide longer life/capacity. The connector is curious, it's 10 wires, 4 red, 4 black, one yellow and one green. All the red wires are tied together (so I suspect just to carry higher current on small wires) as are all the black wires. The yellow and green are interesting.
Upon initial opening, the red and black wires were giving 0v output. This made me think the 'battery pack' had li-ion protection circuit in there and had gone into full discharge protection (i.e. shutting the batteries down). So the first trick was to get them to charge. Plugging the USB power lead in initially didn't show any voltage on these wires either, which really confused me, as I'd assume the tablet would provide power to try and charge the batteries and rely on the charge circuitry to protect it.
In hindsight, I suspect this isn't the case, and the tablet does have sense on it (through the yellow and green wires I think) and so didn't start charging.



I then pulled apart the battery pack (very carefully. Li-ion are very unstable batteries, any damage could cause a cascade accident so please read up on them and do this with caution, know what you're playing with!) and found the control circuit. This was also when I found that the 'battery pack' was two li-ion packs joined together at the top with the control circuitry.
Testing the cell themselves (the metal tabs at the top of the cells) I got a low voltage (around 3.0v) which I'd guess was too low for the circuit to allow output/charge, so it was 'dead'. Reading around, there are ways to revive this circuit, unfortunately I didn't really document how I recovered the battery but it was a combination of keeping the charge on it and probing the sense circuits (My suspicion is my meter combined with voltage applied caused the charge circuit to 'see' a voltage which kicked things back off). I then saw 3.7v on the red and black wires from the Hudl2 cables, which was a good start. Watching it over a minute or so I saw the voltage slowly going up, by 0.01v every few seconds, so it got to 3.9v and hovered for a while. This looked hopeful.
Meanwhile I took it off charge a few times to test the Hudl2 power supply, the adapter gave out 5v as expected, and it had the middle two data pins shorted out, which is a common way of signalling to devices that it was a 'fast/high capacity' charger, so that's why other chargers didn't work right, they did slow/low charging rates.
Over about 30 minutes the voltage went up and up to around 4.0v which looked a good charge voltage for the cells, and it stayed around there, the charger got quite warm (I couldn't check current unfortunately) but I guessed this meant it was charging at a decent rate.
Over a few hours the voltage stayed around 4/4.1v and when removing the charger, I saw the voltage drop to the correct 3.8v supplied on the black and red wires to the Hudl2. However, the charge light would still not come on and the tablet wouldn't power on.
I was using the 'recovery' way of turning it on, that is holding the volume up and power in for 15 seconds, then just power for 15 seconds. This is supposed to recover it should it stop charging. However this wouldn't work. I've tried many combination of power and volume buttons without success now. None will show either the charge light or the power coming on to the tablet (Normally even when low on battery plugging the charge cable in would light the screen up and show a charging battery animation, this didn't trigger either).
So I'm back to suspecting the 'sense' circuitry either in the battery (unlikely as the batteries seemed happy now) or in the Hudl2 itself (most likely now I think). So I turned my attention to the strange additional two wires. The Yellow and Green that came from the battery into the Hudl2 motherboard.
When testing these wires, the yellow shows a constant 0.5v (when tested to black/ground) and the green showed a jumping voltage, my meter only showed around 0.5v for about a second, then 0 then back up again, approx every second changing. This is confusing, I'm unsure what both of these values should be, so cannot determine if these are giving the right output to the Hudl2 to tell it 'all is well'.



This is where I'm up to, the tablet won't power on or show it's charging, I think it's to do with these two sense cables, but not knowing their purpose or correct values cannot 'trick' it into booting or charging, which I suspect will kick a chain reaction and get it back to life.
I've ordered a replacement Li-Ion battery pack for it (Around £10 from eBay) as my suspicion is that if the pack is still damaged/faulty, then these sense wires may be causing the problem. When the new pack arrives the first thing I'll be doing is testing these two leads and see what voltage they give out and what sequence they do, as that may unlock the key to why the unit won't power back up.

As always, I'd appreciate your feedback and comments, if you've had similar problems and solved them please do post back to me, or if you know what the mystery Yellow and Green wires are for let me know in the comments!

11 comments:

  1. Hi did the new battery solve the problem?

    ReplyDelete
    Replies
    1. Hi,
      Unfortunately not, I put another blog post at http://andyb2000.thebmwz3.co.uk/2016/03/tesco-hudl2-battery-problems-and_11.html Which continues and lists what else I found, etc. But ultimately, no I couldn't recover it at all.

      Delete
  2. Hi,

    Any ideas where the wifi antenna is in one of these hudl2 beasties? I've had a rummage about and can't see anything anywhere.

    Wifi has stopped working, seems to be a hardware fault and wanted to check that the antenna hadn't become unplugged.

    Thanks

    ReplyDelete
  3. Thanks for posting. I had pretty much the same experience. Daughter's Hudl2 just stopped working, and eventually even the charge indicators didn't light at all. I called Tesco as it was < 18 months old, but they offered only a partial refund. I'm pretty good at fixing, and have B.Eng in electtonics, so I took it apart, did some metering and concluded a new battery and USB circuit board might help. They didn't. I haven't given up yet, I'll follow up if I get anywhere.

    ReplyDelete
  4. We have TWO hudl 2 and both have gone same way. Won't charge or turn on. Replacing battery and USB port made no difference.

    ReplyDelete
  5. My son has also had this issue on 2 Hudl 2's. I suspect the only way to revive them is to buy a cracked screen Hudl 2 and swap over the entire motherboard.

    ReplyDelete
  6. I fixed 3 that went blank and one of them had a screen go pure white when power button push.
    The ribbon cable going into this https://imgur.com/a/hBbpv

    slot was slightly of at the far right and once I reinserted it correctly, I powered them all on. Sometimes a red Icon of the Battery NOT charging will momentarily appear on screen sometimes not. Is your RED led lighting when charging or powering on ?

    ReplyDelete
  7. This comment has been removed by the author.

    ReplyDelete
    Replies
    1. This comment has been removed by the author.

      Delete
  8. I had the same problem I replaced the charging port but no joy i was going to replace battery but after somebody did and got luck. I took it back to Tesco they said it was out of warranty so how far do you go.

    ReplyDelete
  9. I have replaced a dead hudl2 charging port and battery all i am getting is a faint green light but not always. however still not booting any ideas please

    ReplyDelete